[solved] vmware: wrong/broken keyboard mapping

I’ve installed VMware Server 2.0 ( from 2008/10/29 | Build: 122956) on a 64bit Ubuntu 8.10 (Intrepid Ibex), and set up a Fedora9 and a Ubuntu 8.10 32bit instance. Unfortunately the keyboard mapping was messed up pretty much. If I tried to go up with the arrow key a “save screenshot” window poped up. I only was able to use the navigation keys on the num-pad. A bunch of other keys didn’t work either. Either I was tired or a bit too silly to find the solution for the problem quickly. At the end it was simply a wrong search pattern in Google and laziness to read more thoroughly.

Two solutions for the problem were proposed, but only solution #2 works for a German keyboard. With solution #1 you’re missing the pipe sign ( | ):

  1. echo 'xkeymap.nokeycodeMap = true' >> ~/.vmware/config

  2. insert these lines into ~/.vmware/config, instead of xkeymap.nokeycodeMap = true:

    xkeymap.keycode.108 = 0x138 # Alt_R
    xkeymap.keycode.106 = 0x135 # KP_Divide
    xkeymap.keycode.104 = 0x11c # KP_Enter
    xkeymap.keycode.111 = 0x148 # Up
    xkeymap.keycode.116 = 0x150 # Down
    xkeymap.keycode.113 = 0x14b # Left
    xkeymap.keycode.114 = 0x14d # Right
    xkeymap.keycode.105 = 0x11d # Control_R
    xkeymap.keycode.118 = 0x152 # Insert
    xkeymap.keycode.119 = 0x153 # Delete
    xkeymap.keycode.110 = 0x147 # Home
    xkeymap.keycode.115 = 0x14f # End
    xkeymap.keycode.112 = 0x149 # Prior
    xkeymap.keycode.117 = 0x151 # Next
    xkeymap.keycode.78 = 0x46 # Scroll_Lock
    xkeymap.keycode.127 = 0x100 # Pause
    xkeymap.keycode.133 = 0x15b # Meta_L
    xkeymap.keycode.134 = 0x15c # Meta_R
    xkeymap.keycode.135 = 0x15d # Menu

References:
http://nthrbldyblg.blogspot.com/2008/06/vmware-and-fubar-keyboard-effect.html
https://bugs.launchpad.net/ubuntu/intrepid/+bug/289098

6 thoughts on “[solved] vmware: wrong/broken keyboard mapping

  1. birko

    hi. a have same problem but this solution doesnt work. some keys are still not working like Enter, insert,delete or the winkey :(
    im runinng my os on hp nx6110 notebook

  2. acmelab68 Post author

    @birko
    Hi,
    which language?
    Hm – seems notebooks bahave differently.
    You should try to scan your keycodes yourself, and would be very very nice, if you wourld report back how you did it.

    Use ‘xev’ to find the code for your keys in doubt. Use it on your working machine and in the vm machine, and map them accordingly.

  3. Rodrigo Rodrigues

    Both solutions work, but there are some side effects, in vmware workstation 6.5.1 the unity mode stoped working… after some google I figured out the best solution is to do these modifications in /etc/vmware/config instead of ~/.vmware/config, it solves the side effects and work for all users ;)

Comments are closed.